Back to overview
Degraded

Degraded episode extraction on popular websites

Mar 25 at 08:47am HDT
Affected services
ytdlp.breadcrum.net

Resolved
Mar 25 at 03:07pm HDT

Updates have been deployed. Everything working as usual.

Created
Mar 25 at 08:47am HDT

Episodes are not working on popular video websites right now. Waiting on a fix.